And Some People End Their Troubleshooting When a Web Page Doesn’t Load

July 18, 2016

by — Posted in Personal Writing

file0002042640992

 

Yesterday at around 7PM my internet connection stopped working.  The PS4 stopped loading Netflix and I heard that a web page failed to load from the other room.   I took the obvious first course of action and rebooted the router and the modem.   To my annoyance this didn’t correct the issue.  So the remainder of the night we took to watch movies off of Plex.

This morning the Internet still wasn’t working, so I had to announce on my weekly conference call that I couldn’t do much until things were corrected.  However, without anything better to do I went through and troubleshot the issue a bit further.   Since I couldn’t correct it, I should definitely make sure the issue wasn’t on my end of the connection.

I checked DNS, and I was getting DNS resolution.  Most of my machines were using Google for DNS, but some use the router.  So I checked both method and DNS seemed to be find.  I then moved on to ping testing.   I could ping different sites out there in the world, but some of the responses came back very slow.   There could be a delay just slowing things down.

I started accessing different sites.   Almost all of them would time out, but Facebook and Gmail would load slowly.   My ISP’s own site wouldn’t load at all beyond the first header, but that could have been pulled from cache.  I thought maybe something was blocking HTTP, but not HTTPS.   So I tried other HTTPS sites, and I couldn’t find anymore that would load.   The likely reason is Facebook and Gmail have proxy servers directly located on my ISP’s network and that is why they would work fine.

Email was slow but working.   FTP would connect and then timeout.   So we have two major issues going on.   The first being the slowness.   This was likely increased by constant testing by everyone seeing if things came back yet.   This would lead to a pseudo DDoS attack on the systems.   The second was why no other web pages were loading.

I came to the conclusion that an upstream transparent proxy (or group) had stopped HTTP/HTTPS traffic.   Since other protocols were working that means they likely were not routed through this proxy.   It could also be that a firewall rule was in place blocking the traffic, but since the outage was about 19 hours – that should have been found quickly.   Rebuilding or rerouting  around around a proxy server might take tons of reconfigurations of routers and other servers along the way, so it may have all hinged on that server.

Being a nice guy who had done all the research and troubleshooting – and seeing I could access Facebook, I sent a message onto the ISP of the issue and the symptoms.   Of course it was a Facebook moderator who knows nothing about any of what you just read, they gave me the standard “thank you, we are aware there are outages in your area and we don’t have an ETA for service to resume”.  That person calls it outage when his page doesn’t load and doesn’t look any further than rebooting the modem.

Nothing I found out helped me get connected to the wider world any sooner.   But I understood the problem even though if I called tech support, they would have had no clue what I was talking about.  That’s fine, it’s not monkey and not my circus.   Granted I may throw peanuts at the monkey to amuse me and help me get things done, I’m still at the mercy of the organ grinder to turn the crank.   At least it is all working now.

 

 

Leave a Reply